Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word “yes” if 3 divide evenly into F(n).
Print the word “no” if not.
Sample Input
0
1
2
3
4
5
Sample Output
no
no
yes
no
no
no
应用求模公式
(1) (a + b) % p = (a % p + b % p) % p
(2) (a - b) % p = (a % p - b % p) % p
(3) (a * b) % p = (a % p * b % p) % p
(4) a ^ b % p = ((a % p)^b) % p
如果不用的话会溢出。
代码:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
using namespace std;
int main()
{
int a[1000001],i,j,s;
a[0]=7;a[1]=11;
for(i=2;i<1000001;i++)
{
a[i]=(a[i-1]%3+a[i-2]%3)%3;//只写最后那个%3也可以
}
while(~scanf("%d",&s))
{
if(a[s]%3==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}
本文同步分享在 博客“谙忆”(CSDN)。
如有侵权,请联系 support@oschina.cn 删除。
本文参与“OSC源创计划”,欢迎正在阅读的你也加入,一起分享。